kubeadm join 10.198.64.222:16443 --token iidr24.dydqro5bqu3ow2v4 --discovery-token-ca-cert-hash sha256:2cd339e4f9149264199b1bdf0db2a03620227a4519bf4fd4845edd86803eac94
[preflight] Running pre-flight checks
error execution phase preflight: [preflight] Some fatal errors occurred:
[ERROR FileAvailable--etc-kubernetes-kubelet.conf]: /etc/kubernetes/kubelet.conf already exists
[ERROR Port-10250]: Port 10250 is in use
[ERROR FileAvailable--etc-kubernetes-pki-ca.crt]: /etc/kubernetes/pki/ca.crt already exists
[preflight] If you know what you are doing, you can make a check non-fatal with `--ignore-preflight-errors=...`
To see the stack trace of this error execute with --v=5 or higher
- cni0 IP 대역 불일치로 아래와 같은 에러가 날 경우
network: failed to set bridge addr: "cni0" already has an IP address different from 10.244.6.1/24
$ k describe pod/rook-ceph-detect-version--1-7bxk2 -n rook-ceph
Normal SandboxChanged 12m (x12 over 13m) kubelet Pod sandbox changed, it will be killed and re-created.
Warning FailedCreatePodSandBox 3m44s (x108 over 13m) kubelet (combined from similar events): Failed to create pod sandbox: rpc error: code = Unknown desc = failed to set up sandbox container "6ce5225a4b04ddc9b7bd471d65f4ee03c87687da4b21c9f4d250c59395631222" network for pod "rook-ceph-detect-version--1-7bxk2": networkPlugin cni failed to set up pod "rook-ceph-detect-version--1-7bxk2_rook-ceph" network: failed to set bridge addr: "cni0" already has an IP address different from 10.244.6.1/24
su root
kubeadm reset
systemctl stop kubelet
systemctl stop docker
rm -rf /var/lib/cni/
rm -rf /var/lib/kubelet/*
rm -rf /etc/cni/
ifconfig cni0 down
ifconfig flannel.1 down
ifconfig docker0 down
ip link delete cni0
ip link delete flannel.1